Fix: .NET Framework 4.7 nu este compatibil cu acest sistem de operare

Advise: Click Aici Pentru A Repara Erorile De Windows Și De Performanța Sistemului Optimizarea

.Net Framework este o infrastructură de programare introdusă de Microsoft. Veți avea nevoie de .Net Framework pentru a rula diverse aplicații și servicii diferite. Majoritatea aplicațiilor care necesită .Net Framework sunt livrate și cu fișierele sale de instalare. Deci, va fi instalată automat pe sistemul dvs. atunci când instalați o aplicație. Dar, este posibil să observați o eroare „.NET Framework 4.7 nu este acceptat pe acest sistem de operare” atunci când instalați o aplicație. Această eroare vă va împiedica să instalați cu succes aplicația. Este posibil să vedeți această eroare atunci când încercați să instalați .Net Framework ca o aplicație / serviciu autonomă.

Motivul pentru care se întâmplă această eroare este același ca cel menționat pe mesajul de eroare. Chiar dacă .Net Framework este acceptat pe Windows 10, dar nu este compatibil cu toate versiunile Windows 10. Deci, dacă vedeți acest mesaj, cea mai probabilă cauză a acestei erori este că executați o versiune Windows 10 care nu este compatibil cu .Net Framework.

Metoda 1: Actualizați Windows 10

Singura soluție pentru această problemă este să vă actualizați pur și simplu Windows 10. Este recomandat să verificați actualizările Windows chiar dacă vă aflați pe cea mai recentă versiune a Windows 10. Întrucât problema este cauzată de un sistem de operare incompatibil, instalarea tuturor Windows 10 disponibile actualizările vor rezolva cel mai probabil problema. Puteți verifica, de asemenea, versiunea exactă a Windows 10 și versiunea cerută de .Net Framework urmând pașii de mai jos.

  1. Țineți tasta Windows și apăsați R
  2. Tastați winver și apăsați Enter

  1. Versiunea dvs. trebuie menționată în fereastra recent deschisă. Numărul după versiune (în a doua linie) este numărul dvs. de versiune. Numărul ar trebui să fie 1507 sau 1709. Primele 2 cifre sunt anul și a doua 2 reprezintă luna. Deci, dacă aveți o versiune 1709, atunci înseamnă că executați o versiune lansată pe septembrie 2017

  1. Acum trebuie să vă asigurați că aveți versiunea Windows 10 compatibilă cu .Net Framework. Faceți clic aici și faceți clic pe Cerințe de sistem

Dacă te uiți la secțiunea Sistem de operare acceptat, se precizează actualizarea Windows 10 Anniversary și Windows 10 Creators . Deoarece mulți oameni nu sunt familiarizați cu numerele de versiune asociate cu actualizările Aniversare și Creatori, le-am menționat mai jos

  • Actualizare noiembrie (1511)
  • Actualizare aniversară (14393)
  • Actualizare Creatori (1703)
  • Actualizare Creatori Toamna (1709)
  • Actualizare Creatori de primăvară (1803)

După cum vedeți, Anniversary Update are numărul de versiune 14393, iar Creators Update are o versiune 1703. Deci, dacă aveți o versiune mai mică decât 14393, atunci nu veți putea instala .Net Framework 4.7 pe Windows 10. Acum pur și simplu actualizați Windows și asigurați-vă că aveți cea mai recentă versiune Windows 10 și încercați din nou.

Articole Interesante